Backup Failure - Milton Keynes
Incident Report for Pulsant Service
Resolved
This issue has been resolved and service has been restored.
Posted Jul 30, 2020 - 10:38 BST
Investigating
We've been alerted to failures in our backup services based in Milton Keynes.

We're currently investigating to determine scope of the issue alongside investigating the cause.
Posted Jul 30, 2020 - 10:09 BST
This incident affected: Business Continuity (Cloud Backup (Asigra) Milton Keynes).