Comodo Root Certificate Expired - Unable to launch Citrix Desktop
Incident Report for Pulsant Service
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 14:00 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2020 - 12:08 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 01, 2020 - 11:03 BST
This incident affected: Cloud Services (Compute).