Citrix performance issues
Incident Report for Pulsant Service
Resolved
Engineers have carried out extensive investigations, however unfortunately have been unable to determine a root cause for the degraded performance of Citrix.

Service has restored to normal and no further performance issues being seen.
Posted Jun 05, 2023 - 10:05 BST
Monitoring
Engineers have carried out extensive investigations, however unfortunately have been unable to determine a root cause for the degraded performance of Citrix.

Pulsant Engineers will continue to monitor.
Posted Jun 02, 2023 - 18:47 BST
Investigating
Pulsant engineers are currently investigating degraded Citrix performance.
Posted Jun 02, 2023 - 15:09 BST
This incident affected: Data Centre Services (Milton Keynes).