Limited access to Croydon Data Centre LN-1

Incident Report for Pulsant Service

Resolved

This incident has been resolved.
Posted Jul 06, 2025 - 16:53 BST

Monitoring

Currently the access road to Croydon Data centre LN-1 is closed due a skip plant fire just down the road. No data centre services are affected. Public access is still available on foot via the green field to the side of the data centre, but main on road parking is very congested.
Posted Jul 06, 2025 - 13:22 BST
This incident affected: Data Centre Services (LN-1 - South London).