Virgin Media Outage in the Croydon Area

Incident Report for Pulsant Service

Resolved

The service has remained stable since 16:00
Posted Dec 03, 2025 - 22:21 GMT

Monitoring

Pulsant are now seeing a recovery of client services in the Croydon area.

Pulsant will follow up with Virgin Media and will continue to monitor.

If you are still seeing an impact please contact Pulsant Support.
Posted Dec 03, 2025 - 15:32 GMT

Investigating

Pulsant are aware of a Virgin Media outage in the Croydon area causing a loss of service to clients.

Virgin Media are conducting checks with in the area and Pulsant are expecting updates soon.
Posted Dec 03, 2025 - 14:57 GMT
This incident affected: Data Centre Services (LN-1 - South London).