Citrix EU Connection Issues
Incident Report for Pulsant Service
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 14:24 GMT
Update
Current update from Citrix - Status is UP.

Post mitigation most of the impacted customers are able to launch apps and desktops. We continue to monitor.
Posted Nov 08, 2024 - 11:16 GMT
Monitoring
Citrix Status page update
'We have identified the root cause and are applying mitigations now. Some of the impacted customers should see successful DaaS launches as we they are recovering.

https://status.cloud.com/incidents/651542
Posted Nov 08, 2024 - 10:42 GMT
Investigating
Pulsant have been made aware of an ongoing incident impacting Citrix EU Customers ' Few EU customers could not launch apps and desktops through DaaS'

For up to date information - https://status.cloud.com/incidents/651542
Posted Nov 08, 2024 - 10:10 GMT