Croydon Data Centre (LN-1) access road closed

Incident Report for Pulsant Service

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 10:30 BST

Update

Please be advised that the public highway Imperial Way, which leads to Croydon Data Centre (LN-1) has now reopened and traffic can pass as normal. The normal authorised access to the Data Centre has been resumed.

We thank you for your patience and understanding during this time.
Posted Jun 21, 2025 - 14:29 BST

Identified

Please be advised that the public highway Imperial Way, which leads to Croydon Data Centre (LN-1) has been closed until further notices, meaning no vehicle access to the data centre.

Pulsant will keep everyone advised when the road is re-opened.

We thank you for your understanding and patience during this time. Please contact the support team to provide further assistance.
Posted Jun 20, 2025 - 08:59 BST
This incident affected: Data Centre Services (LN-1 - South London).