BT Copper broadband services
Incident Report for Pulsant Service
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 11:09 BST
Update
We are aware that issues are still being experienced and this has been escalated to BT.

We will provide updates as soon as possible.
Posted Apr 08, 2024 - 11:57 BST
Investigating
We have received multiple reports of outages from clients on BT copper broadband, and BT has been duly made aware of these occurrences.

These disruptions have been attributed to adverse weather conditions, leading to fluctuations in connections characterised by drops and intermittent restores.

Service restoration is estimated to be completed by Monday.

Updates will be provided as soon as possible.
Posted Apr 06, 2024 - 17:29 BST