Duo Authentication Services
Incident Report for Pulsant Service
Resolved
Duo services are reported as stable, please check https://status.duo.com for further details.
Posted Mar 01, 2021 - 11:05 GMT
Monitoring
Duo Engineering team's remedial actions have resulted in restoring the phone call authentication services for all regions.
Posted Mar 01, 2021 - 10:48 GMT
Update
Duo Engineering team's remedial actions have resulted in restoring the phone call authentication services for a majority of regions.

Please continue to use alternative authentication methods like Push or SMS and check back here or subscribe to updates for any changes.
Posted Mar 01, 2021 - 10:10 GMT
Identified
Our partner Duo is currently investigating an issue causing phone delivery issues on all of our deployments and is working to correct the issue as soon as possible.
Please, where possible, use alternative authentication methods, like push or SMS.
Posted Mar 01, 2021 - 09:37 GMT