Investigating issues with our Citrix Cloud Desktop service.
Incident Report for Pulsant Service
Resolved
This incident is now resolved, we will continue to work with Citrix to identify root cause.
Posted Sep 08, 2020 - 15:57 BST
Investigating
We’re currently investigating reports of a potential service interruption with our Cloud Desktop service. Engineers are working to identify the root cause and restore service.

We apologise for any inconvenience this is causing and will post another update in 30 minutes or sooner as we learn more.

Should you have any questions, please contact support by emailing support@pulsant.com or by calling us on 0845 1199 999.
Posted Sep 08, 2020 - 15:40 BST
This incident affected: Managed Cloud (Cloud Desktop Milton Keynes).