Issues with 123-reg
Incident Report for Pulsant Service
Resolved
This incident has been resolved.
Posted Dec 05, 2016 - 10:57 GMT
Identified
We've noticed intermittent issues with externally hosted sites on 123-reg.
We will continue to monitor and watch for updates on https://twitter.com/123reg
Posted Nov 28, 2016 - 10:27 GMT